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1 Introduction And Scope

Reflex is the ESO Recipe Flexible Execution Workbench, an environment to run ESO VLT pipelines which
employs a workflow engine (Kepler1) to provide a real-time visual representation of a data reduction cascade,
called a workflow, which can be easily understood by most astronomers. The basic philosophy and concepts
of Reflex have been discussed by Freudling et al. (2013, AÂ in press). Please reference this article if you use
Reflex for your research.

Reflex and the data reduction workflows have been developed at ESO and they are fully supported. If you have
any issue, please contact usd-help@eso.org for further support.

This document is a tutorial designed to enable the user to employ the IIINSTRUMENT workflow to reduce
his/her data in a user-friendly way, concentrating on high-level issues such as data reduction quality and signal-
to-noise (S/N) optimisation.

A workflow accepts science and calibration data, as delivered to PIs in the form of PI-Packs (until October
2011) or downloaded from the archive using the CalSelector tool2 and organises them into DataSets, where each
DataSet contains one science object observation (possibly consisting of several science files) and all associated
raw and static calibrations required for a successful data reduction. The data organisation process is fully
automatic, which is a major time-saving feature provided by the software. The DataSets selected by the user
for reduction are fed to the workflow which executes the relevant pipeline recipes (or stages) in the correct
order. Full control of the various recipe parameters is available within the workflow, and the workflow deals
automatically with optional recipe inputs via built-in conditional branches. Additionally, the workflow stores the
reduced final data products in a logically organised directory structure employing user-configurable file names.

Add here some explanation about this specific workflow. Instrument modes supported, etc...

1http://kepler-project.org
2http://www.eso.org/sci/archive/calselectorInfo.html

mailto:usd-help@eso.org
http://kepler-project.org
http://www.eso.org/sci/archive/calselectorInfo.html
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2 Software Installation

The software pre-requisites for Reflex 2.6 may be found at:
http://www.eso.org/sci/software/pipelines/reflex_workflows

To install the Reflex 2.6 software and demo data, please follow these instructions:

1. From any directory, download the installation script:

wget ftp://ftp.eso.org/pub/dfs/reflex/install_reflex

2. Make the installation script executable:

chmod u+x install_reflex

3. Execute the installation script:

./install_reflex

and the script will ask you to specify three directories: the download directory <download_dir>, the
software installation directory <install_dir>, and the directory to be used to store the demo data
<data_dir>. If you do not specify these directories, then the installation script will create them in the
current directory with default names.

4. You will be given a choice of pipelines (with the corresponding workflows) to install. Please specify the
numbers for the pipelines you require, separated by a space, or type “A” for all pipelines.

5. To start Reflex, issue the command:

<install_dir>/bin/reflex

It may also be desirable to set up an alias command for starting the Reflex software, using the shell com-
mand alias. Alternatively, the PATH variable can be updated to contain the <install_dir>/bin
directory.

http://www.eso.org/sci/software/pipelines/reflex_workflows
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3 Demo Data

Add some explanation about the demo data used.
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4 Quick Start: Reducing The Demo Data

Add here a two pages maximum explanation on how to quickly reduce the demo data set.
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5 About The Reflex Canvas

5.1 Saving And Loading Workflows

In the course of your data reductions, it is likely that you will customise the workflow for various data sets, even
if this simply consists of editing the ROOT_DATA_DIR to a different value for each data set. Whenever you
modify a workflow in any way, you have the option of saving the modified version to an XML file using File
-> Export As (which will also open a new workflow canvas corresponding to the saved file). The saved
workflow may be opened in subsequent Reflex sessions using File -> Open. Saving the workflow in the
default format (.kar) is only advised if you do not plan to use the workflow in another computer.

5.2 Buttons

At the top of the Reflex canvas are a set of buttons which have the following useful functions:

• - Zoom in.

• - Reset the zoom to 100%.

• - Zoom the workflow to fit the current window size (Recommended).

• - Zoom out.

• - Run (or resume) the workflow.

• - Pause the workflow execution.

• - Stop the workflow execution.

The remainder of the buttons (not shown here) are not relevant to the workflow execution.

5.3 Workflow States

A workflow may only be in one of three states: executing, paused, or stopped. These states are indicated by the

yellow highlighting of the , , and buttons, respectively. A workflow is executed by clicking the
button. Subsequently the workflow and any running pipeline recipe may be stopped immediately by clicking the

button, or the workflow may be paused by clicking the button which will allow the current actor/recipe

to finish execution before the workflow is actually paused. Note that after clicking the button, it is possible
that more than one actor is executed, since this behaviour depends on the workflow scheduling. For instance, if
there are two actors in parallel, and you pause the workflow while one is being executed, then both of them will
be executed before the workflow is actually paused. After pausing, the workflow may be resumed by clicking

the button again.
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6 The IIINSTRUMENT Workflow

The IIINSTRUMENT workflow canvas is organised into a number of areas. From top-left to top-right you will
find general workflow instructions, directory parameters, and global parameters. In the middle row you will
find five boxes describing the workflow general processing steps in order from left to right, and below this the
workflow actors themselves are organised following the workflow general steps.

6.1 Workflow Canvas Parameters

The workflow canvas displays a number of parameters that may be set by the user. Under “Setup Directories” the
user is only required to set the RAWDATA_DIR to the working directory for the DataSet(s) to be reduced, which,
by default, is set to the directory containing the demo data. The RAWDATA_DIR is recursively scanned by the
Data Organiser actor for input raw data. The directory CALIB_DATA_DIR, which is by default within
the pipeline installation directory, is also scanned by the Data Organiser actor to find any static calibrations
that may be missing in your DataSet(s). If required, the user may edit the directories BOOKKEEPING_DIR,
LOGS_DIR, TMP_PRODUCTS_DIR, and END_PRODUCTS_DIR, which correspond to the directories where
book-keeping files, logs, temporary products and end products are stored, respectively (see the Reflex User
Manual for further details; [1]).

Under the “Global Parameters” area of the workflow canvas, the user may set the FITS_VIEWER parameter to
the command used for running his/her favourite application for inspecting FITS files. Currently this is set by
default to fv, but other applications, such as ds9, skycat and gaia for example, may be useful for inspecting
image data.

By default the EraseDirs parameter is set to false, which means that no directories are cleaned before
executing the workflow, and the recipe actors will work in Lazy mode (see Section 6.2.2), reusing the previous
pipeline recipe outputs where input files and parameters are the same as for the previous execution, which saves
considerable processing time. Sometimes it is desirable to set the EraseDirs parameter to true, which
forces the workflow to recursively delete the contents of the directories specified by BOOKKEEPING_DIR,
LOGS_DIR, and TMP_PRODUCTS_DIR. This is useful for keeping disk space usage to a minimum and will
force the workflow to fully rereduce the data each time the workflow is run.

The parameter RecipeFailureMode controls the behaviour in case that a recipe fails. If set to Continue,
the workflow will trigger the next recipes as usual, but without the output of the failing recipe, which in most of
the cases will lead to further fails of other recipes without the user actually realising of it. This mode might be
useful for unattended processing of large number of datasets. If set to Ask, a pop-up window will ask whether
the workflow should stop or continue. This is the default. Additionally, the Stop mode will stop the workflow
execution inmediatly.

The parameter GlobalInteractivity controls whether the interactive windows will appear for those win-
dows which are enabled by default. The possible values are true, false. Take into account that some
windows are disabled in the default configuration and therefore are not affected by this parameter.

The parameter ProvenanceExplorerEnabled controls whether the ProvenanceExplorer actor will
show its window or not. The possible values are true, false.
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6.2 Workflow Actors

6.2.1 Simple Actors

Simple actors have workflow symbols that consist of a single (rather than multiple) green-blue rectangle. They
may also have a logo within the rectangle to aid in their identification. The following actors are simple actors:

• - The Data Organiser actor.

• - The Data Set Chooser actor.

• - The Fits Router actor

• - The Product Renamer actor.

• - The Provenance Explorer actor.

Access to the parameters for a simple actor is achieved by right-clicking on the actor and selecting Configure
Actor. This will open an “Edit parameters” window. Note that the Product Renamer actor is a jython
script (Java implementation of the Python interpreter) meant to be customised by the user (by double-clicking
on it).

Add here a description of this workflow specific actors (probably including some composite actors).

6.2.2 Lazy Mode

By default, all recipe executer actors in a pipeline workflow are “Lazy Mode” enabled. This means that when
the workflow attempts to execute such an actor, the actor will check whether the relevant pipeline recipe has
already been executed with the same input files and with the same recipe parameters. If this is the case, then the
actor will not execute the pipeline recipe, and instead it will simply broadcast the previously generated products
to the output port. The purpose of the Lazy mode is therefore to minimise any reprocessing of data by avoiding
data rereduction where it is not necessary.

One should note that the actor Lazy mode depends on the contents of the directory specified by
BOOKKEEPING_DIR and the relevant FITS file checksums. Any modification to the directory contents and/or
the file checksums will cause the corresponding actor when executed to run the pipeline recipe again, thereby
rereducing the input data.

The forced rereduction of data at each execution may of course be desirable. To force a rereduction of all data
for all RecipeExecuter actors in the workflow (i.e. to disable Lazy mode for the whole workflow), set the
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EraseDirs parameter under the “Global Parameters” area of the workflow canvas to true. This will then
remove all previous results as well. To force a rereduction of data for any single RecipeExecuter actor
in the workflow (which will be inside the relevant composite actor), right-click the RecipeExecuter actor,
select Configure Actor, and uncheck the Lazy mode parameter tick-box in the “Edit parameters” window
that is displayed.

Add here a description of the workflow steps like Data organisation, routing, creation of calibration files and
science reduction.

Add here a description on how to optimise the results of the workflow.
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7 Frequently Asked Questions

• Where are my intermediate pipeline products? Intermediate pipeline products are stored in the direc-
tory <TMP_PRODUCTS_DIR> (defined on the workflow canvas) and organised further in directories by
pipeline recipe.

• Can I use different sets of bias frames to calibrate my flat frames and science data? Yes. In fact this
is what is currently implemented in the workflow(s). Each file in a DataSet has a purpose attached to it
([1]). It is this purpose that is used by the workflow to send the correct set of bias frames to the recipes
for flat frame combination and science frame reduction, which may or may not be the same set of bias
frames in each case.

• Can I launch Reflex from the command line? Yes, use the command:

reflex -n <workflow_path>/<workflow>.xml

The -n option will set all the different optiions to Kepler and the workflows that avoid any graphical
display (including pipeline interactive windows). Note that this mode is not fully supported, and the user
should be aware that the path to the workflow must be absolute and even if no GUI elements are shown,
it still requires a connection to the window manager.

• How can I add new actors to an existing workflow? You can drag and drop the actors in the menu
on the left of the Reflex canvas. Under Eso-reflex -> Workflow you may find all the actors
relevant for pipeline workflows, with the exception of the recipe executer. This actor must be manu-
ally instantiated using Tools -> Instantiate Component. Fill in the “Class name” field with
org.eso.RecipeExecuter and in the pop-up window choose the required recipe from the pull-
down menu. To connect the ports of the actor, click on the source port, holding down the left mouse
button, and release the mouse button over the destination port. Please consult the Reflex User Manual
([1]) for more information.

• How can I broadcast a result to different subsequent actors? If the output port is a multi-port (filled
in white), then you may have several relations from the port. However, if the port is a single port (filled in
black), then you may use the black diamond from the toolbar. Make a relation from the output port to the
diamond. Then make relations from the input ports to the diamond. Please note that you cannot click to
start a relation from the diamond itself. Please consult the Reflex User Manual ([1]) for more information.

• How can I run manually the recipes executed by Reflex? If a user wants to re-run a recipe on the
command line he/she has to go to the appropriate reflex_book_keeping directory, which is generally
reflex_book_keeping/<workflow>/<recipe_name>_<number> There, subdirectories exist with the time
stamp of the recipe execution (e.g. 2013-01-25T12:33:53.926/). If the user wants to re-execute the most
recent processing he/she should go to the latest directory and then execute the script cmdline.txt.
Alternatively, to ensure that the path to esorex is the correct one, the user can execute

ESOREX_CONFIG="INSTALL_DIR/etc/esorex.rc"
INSTALL_DIR/bin/esorex --recipe-config=<recipe>.rc <recipe> data.sof
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where INSTALL_DIR is the directory where Reflex and the pipelines were installed. If the user knows
the name of the input raw files for the recipe, the correct directory among the many time stamps can be
found via grep <raw_file> */data.sof. Afterwards the procedure is the same as before. The
products will appear in the directory from which the recipe is called, and not in the reflex_tmp_products
or reflex_end_products directory, and they will not be renamed.

Add here a section on troubleshooting problems.
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[1] Forchì V. Reflex User’s Manual. ESO/SDD/DFS, http://www.eso.org/gasgano/ , 0.7 edition, 2012. VLT-
MAN-ESO-19000-5037. 12, 15

http://www.eso.org/gasgano/
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